23 August 2012 แก้ปัญหา Wi-Fi เอ๋อเหรอ บน MacOSX Lion

ห่างหายจากการเขียนบล็อกเกือบปี ดองมาจนได้เวลาสักที เลยเอาเรื่องนี้มาเขียนลงบล็อกเลยดีกว่า เก็บไว้หลายเดือนละ ปัญหานี้เล่นผมปวดขมับเลย อยู่ๆสัญญาณ Wireless จากเครื่อง iMac มัน Drop ติดๆดับๆ แต่อุปกรณ์อย่างมือถือ, iPad ไม่ยักกะเป็นเหมือนกัน คิดว่าเครื่อง iMac ปีกว่าๆถึงกาลจะต้องยกไปเข้าศูนย์แล้ว

เกริ่นสักนิด….

เครื่องคอมที่ผมใช้งานอยู่เป็น iMac รุ่นปี 2010 ลงระบบ MacOSX Lion 10.7.4 ใช้งานมาได้ดีไม่มีปัญหาอะไร ร่วมกับ ASUS WL-500gP V2 (54Mbps) Wireless Router แต่ถูกปลดประจำการหลังจากใช้งานมานานโข (แม้มันจะสามารถทำงานได้ดีอยู่) เพราะได้สาวใหม่แรงฤทธิ์ราคาแสนถูก (790฿) มาจากงานคอมมาร์ท กลางปี 55 ที่ผ่านมา คือเจ้า D-Link DIR-605L (300Mbps) แถมมี App ฟรีใน Android และ iOS ให้โหลดเพื่อสามารถดูข้อมูลจากอุปกรณ์ตัวนี้ได้อีก ไม่พลาดสอยมาอยู่ในอ้อมกอด

ปัญหาที่เกิดขึ้น

ช่วงแรกใช้งาน ปกติไม่มีปัญหาอะไรหรอกครับ แต่เครื่องคอมก็มีสัญญาณ Wifi วูปหายเป็นครั้งคราว อาจเพราะเปิดใช้งานไม่บ่อย แต่หลังจากเปิดคอมมาใช้งานอย่างต่อเนื่อง อาการสัญญาณเน็ตหลุดพบบ่อย และหนักขึ้น ขนาดจะเปิดเว็บ Wireless สัญญาณเต็ม แต่เข้าเปิดเว็บไม่ได้ซะงั้น ต้องทำการ Turn Wifi off และ On ใหม่ถึงจะกลับมาใช้งานได้

สัญญาณ Wireless เต็ม...แต่เปิดเว็บไม่ได้

สัญญาณ Wireless เต็ม…แต่เปิดเว็บไม่ได้

ลองหยิบมือถือ และ iPad รับสัญญาณกับ Wireless กลับใช้งาน เข้าเน็ตได้ตามปกติ แสดงว่า เครื่อง iMac ฉานน เจ๊งแน่ เลยกลับไปใช้ Wireless เก่า กลับไม่มีอาการดังกล่าวเลยละพี่น้อง แสดงว่า D-Link เธอคือจุดอ่อน ทำให้น้อง iMac ฉาน เอ๋อ…เหรอ

ทดสอบอีกครั้ง โดย Restore Wireless D-Link เป็นค่าเดิมจากโรงงาน และลองอีกรอบ อาการเหมือนเดิม จึงลองไปดู Log Status  เลยรู้ว่า มันหลุดบ่อยและต่อใหม่ ทุกระยะ ดูรูปแล้วละกัน

สัญญาณ WiFi หลุด และ ต่อเป็นระยะๆ ช่วง1

สัญญาณ WiFi หลุด และ ต่อเป็นระยะๆ ช่วง1

สัญญาณ WiFi หลุด และ ต่อเป็นระยะๆ ช่วง2

สัญญาณ WiFi หลุด และ ต่อเป็นระยะๆ ช่วง2

วิธีแก้ปัญหา

เลยลองหาข้อมูลใน Google ก็มีวิธีแก้ ลบค่า นู้น นี่นั้นใน iMac ก็ไม่สำเร็จสักกะวิธี เลยมาเจอบทความ Mac OS X Lion Wi-Fi problems สรุปประมาณว่า…

ปัญหานี่เกิดจาก driver Atheros v4.0 ใน MacOSX Lion มีปัญหากับ Chipset wireless บางรุ่นในเครื่อง iMac (ดันเป็นรุ่นของผมซะด้วย) เลยให้ถอยกลับไปให้ driver Atheros v3.2 ปัญหาดังกล่าวก็จะหมดไป ว่าแล้วก็ลองโหลดไฟล์นี้มาลงในเครื่องซะเลย

ไฟล์ : Atheros v3.2

วิธีการติดตั้งง่ายมากครับ หลังจากโหลดไฟล์ Atheros v3.2 ก็ให้ดับเบิลคลิ๊กเพื่อแตกไฟล์ออกมา จะมีไฟล์ 2 ตัว คือ IO80211Family.kext กับ Kext Utility ให้ลากไฟล์ IO80211Family.kext ไปใส่ใน Kext Utility

ลากไฟล์ IO80211Family.kext ไปใส่ใน Kext Utility

ลากไฟล์ IO80211Family.kext ไปใส่ใน Kext Utility

หลังจากนั้น มันจะเปิดหน้าจอแอพ Kext Utility และคัดลอก IO80211Family.kext ไปแทนที่ตัวเดิมให้อัตโนมัติ…  โดยจะทำการ backup ไฟล์ตัวเดิมเป็น IO80211Family.kext.bak ไว้ที่ตู้ /System/Library/Extensions/

แอฟ Kext Utility คัดลอกไปทับไฟล์ในตู้ระบบ

แอฟ Kext Utility คัดลอกไปทับไฟล์ในตู้ระบบ

แล้วลองทำการ Restart เครื่องคอม อาการดังกล่าวหายปลิดทิ้งเลยละ ลองมาแล้ว……. ล่าสุดผมลองกับ MacOSX Mountain Lion 10.8 อาการดังกล่าวไม่มีแล้วนะครับ คาดว่า Apple ทำการปรับปรุง Driver ให้ทำร่วมกันกับ chipset Wifi ของบางรุ่นสมบูรณ์แล้ว เย้ เย้…..

สำหรับใครสงสัยวิธีแก้ปัญหาลองดูคลิปตามนี้ก็ได้ครับ

Tags: ,

2 Responses to “แก้ปัญหา Wi-Fi เอ๋อเหรอ บน MacOSX Lion”

  1. ขอบคุณมากครับสำหรับข้อมูล ผมใช้ประโยชน์วันนี้ด้วยครับ

  2. myStudio says:

    os x 10.6.8 เจอปัญหาคล้ายกันเลยครับแต่ใช้วิธีนี้แล้วไม่หายครับ
    พอจะมีวิธีอื่นๆ บ้างมั้ยครับ? รบกวนท่านหนุ่มหน่อยครับ

Leave a Reply